Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Nov 19, 2025 - 10:00 GMT
Scheduled
Dear Customer,
This is a courtesy email to inform you in regards to some upcoming maintenance being carried out on our Veeam Cloud Connect Infrastructure.
WHEN: 19th November 2025 10am – 3:30pm
WHERE: Veeam Cloud Connect Infrastructure
WHY: We are applying our scheduled Windows Update patching to our Veeam Cloud Connect infrastructure to keep our platform fully patched. These are usually applied on the 3rd Wednesday of each month. I’m now going to start sending courtesy emails 48 hours before it’s implemented so all customers are aware of any errors that may show and can plan if required accordingly. In order to apply the updates, the Veeam services need to be stopped for a short time during the reboot process.
No action is required as a result of this notification.
If you have any questions relating to this event, please contact the Service Desk team, or speak to your account manager.
Posted Nov 17, 2025 - 10:39 GMT
This scheduled maintenance affected: Veeam Cloud Connect Backup Service, Veeam Cloud Connect Replication Service, and Veeam Service Provider Console.