A possible root cause has been identified and a fix will be implemented
Posted Mar 03, 2026 - 10:42 GMT
Update
The team is continuing to investigate this issue as a priority, Customers are encourage to reach out to a member of the team via email (servicedesk@virtualdcs.co.uk) or the live chat function if restores are required.
Posted Feb 27, 2026 - 10:39 GMT
Investigating
Some exchange restores may provide the error message "Failed to restore folder: The certificate certificate does not have a private key." when attempting to restore to original location. This is being investigated by the team.
Posted Feb 26, 2026 - 10:49 GMT
This incident affects: CloudCover365 Portal and CloudCover365 Services.