We have been monitoring the platform since, and it has been stable and performing as usual.
Please reach out to out support team at servicedesk@virtualdcs.co.uk if you have any further issues still ongoing.
Posted Jun 25, 2026 - 11:47 BST
Monitoring
The fix has now been deployed and successfully validated. Test backup jobs have completed successfully, and affected tenants have been re-enabled.
We are continuing to closely monitor the platform to ensure services remain stable and that backup jobs are processing as expected. We will provide a further update should there be any significant developments.
Posted Jun 19, 2026 - 19:39 BST
Update
To minimise disruption while we continue our investigation, affected tenants are being temporarily disabled. During this time, Veeam Cloud Connect backup jobs for affected tenants may fail with the message "Your tenant is disabled". This behaviour is expected and forms part of our mitigation efforts while a permanent resolution is being implemented.
We believe we have identified the underlying cause of the issue and are currently validating a potential fix within our lab environment. Testing remains ongoing, and we will provide a further update as soon as validation has been completed.
Posted Jun 19, 2026 - 15:22 BST
Identified
Our investigation is ongoing and, working alongside the vendor, we believe we have identified the underlying cause of the issue affecting some Veeam Cloud Connect backup jobs. We are currently validating a potential fix within our lab environment and will provide a further update once testing has been completed.
Further updates to follow at 14:00
Posted Jun 19, 2026 - 12:02 BST
Investigating
We are aware of an issue affecting some customers' veeam cloud connect backup jobs this morning. We are actively looking into this and will update once progress is made.
Posted Jun 19, 2026 - 09:21 BST
This incident affected: Veeam Cloud Connect Backup Service.