Users Experiencing Intermittent Errors

Incident Report for DCS

Resolved

This incident has been resolved.
Posted Feb 11, 2026 - 09:21 GMT

Monitoring

Our team has received reports of users experiencing issues following our most recent updates.

After investigation, we identified the root cause as a caching issue.

To resolve this, customers should refresh their browser’s local cache. Instructions can be found below:
• Google Chrome: https://support.google.com/accounts/answer/32050
• Microsoft Edge: https://www.microsoft.com/en-us/edge/learning-center/how-to-manage-and-clear-your-cache-and-cookies
• Mozilla Firefox: https://support.mozilla.org/en-US/kb/how-clear-firefox-cache
Posted Feb 10, 2026 - 10:42 GMT
This incident affected: CloudCover365 Portal.