We have been monitoring the platform closely with our service partner, and the network has remained stable since 11:00 on 23/03. As stability has been confirmed, we are now closing this incident. If you are still experiencing any issues, please contact servicedesk@virtualdcs.co.uk.
Posted Mar 24, 2026 - 14:07 GMT
Update
This incident has been linked to a fault with one of our provider's upstream network partners, who has acknowledged the issue. As this provider carries a significant volume of internet traffic, impact was widespread, though variable depending on routing paths. Services have remained stable since 11am. We are continuing to monitor.
Posted Mar 23, 2026 - 16:55 GMT
Update
All services look to be operational again, we're still monitoring this and confirming root cause with our provider
Posted Mar 23, 2026 - 11:58 GMT
Monitoring
Our partner appears to have stabilised the connectivity for now. Services should now be back to normal. They are still investigating the root cause and we will update once we hear back from them.
Posted Mar 23, 2026 - 11:27 GMT
Identified
We have identified an issue with an upstream network connection. This is not isolated to DCS and is part of a wider problem affecting multiple partners. Our upstream provider is working to stabilise the connection as a priority. We will continue to post updates as soon as more information becomes available.
Posted Mar 23, 2026 - 11:05 GMT
Update
Our engineers are continuing to look into this
Posted Mar 23, 2026 - 10:54 GMT
Investigating
We are currently experiencing outage issues across multiple sites. Our engineers are currently looking into this as a P1 issue.