CloudConnect and Geo-Failover Replication intermittent issues

Incident Report for DCS

Resolved

These issues have been resolved by our engineers, please log any continued issues as normal with us
Posted Dec 18, 2025 - 15:49 GMT

Update

We're continuing to investigate and are working towards a solution currently
Posted Dec 18, 2025 - 15:10 GMT

Update

Our engineers continue to look into these issues. Progress will be posted here
Posted Dec 18, 2025 - 14:28 GMT

Update

Our engineers are continuing to investigate and are working towards a solution
Posted Dec 18, 2025 - 12:44 GMT

Update

We are continuing to investigate these issues. Updates will be posted here as they are made
Posted Dec 18, 2025 - 11:02 GMT

Investigating

We are currently looking into intermittent issues with CloudConnect and Geo-Failover Replication. Our engineers are working to identify and resolve these issues
Posted Dec 18, 2025 - 10:20 GMT
This incident affected: Veeam Cloud Connect Backup Service, Veeam Cloud Connect Replication Service, and Geo-Failover Replication.