Restore screen issue 'Please try again. If the issue persists, contact support'

Incident Report for DCS

Resolved

This is resolved now by our development team. Please contact us via email or live chat if you continue to have any issues.
Posted May 22, 2026 - 14:15 BST

Monitoring

A fix has been implemented as part of the latest V26.5 release and we are now monitoring the results.
Posted May 14, 2026 - 17:47 BST

Identified

Our developers have written a fix for this which is currently being tested in our lab environment. This will be updated once we have pushed this fix publicly and confirmed working.
If you require a restore in the meantime, don't hesitate to reach out to the CloudCover365 team via Live Chat or email and we can manually run this for you.
Posted May 13, 2026 - 16:42 BST

Investigating

We are aware of an issue affecting some restores at the point where you select what items to restore being met with an error message 'Please try again. If the issue persists, contact support'. This seems to have occurred from our latest patch. Our developers are currently looking into this.
If you require a restore don't hesitate to reach out to the CloudCover365 team via Live Chat or email and we can manually run this for you.
Posted May 12, 2026 - 13:44 BST
This incident affected: CloudCover365 Portal and CloudCover365 Services.