Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Apr 09, 2025 - 13:30 BST
Scheduled
An engineer will be attending site to replace a module in one of our strorage arrays. We do not expect any impact. but platform is at risk during this time
Posted Apr 09, 2025 - 12:15 BST
This scheduled maintenance affected: Hosting Platform.