Cloudflare Intermittent outages

Incident Report for virtualDCS

Update

We are actively attempting to re-route traffic to mitigate the impact; however, our supplier’s service remains difficult to access, which is currently inhibiting this step.

Our team continues to monitor the situation closely and will provide further updates as soon as we have more information or successfully implement a workaround.

Thank you for your continued patience.
Posted Nov 18, 2025 - 13:09 GMT

Update

We are continuing to monitor for any further issues.
Posted Nov 18, 2025 - 12:07 GMT

Monitoring

We are currently experiencing intermittent downtime due to a global network issue affecting our Cloud Delivery Network provider (Cloudflare). These errors appear to be transient, and our team is actively monitoring the situation.
If the issue persists, we may implement a temporary workaround to minimise impact. We will continue to provide updates as more information becomes available.
Thank you for your patience and understanding.
Posted Nov 18, 2025 - 12:05 GMT
This incident affects: CloudCover365 Portal and Veeam Service Provider Console.