Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Nov 20, 2025 - 14:30 GMT
Scheduled
Dear Customer,
This is a courtesy email to inform you in regards to some upcoming emergency maintenance being carried out on our Veeam Cloud Connect Service Provider Console.
WHEN: 20th November 2025 2:30pm-3:30pm
WHERE: Veeam Cloud Connect Service Provider Console
WHY: We are applying some Veeam updates to our VSPC environment which will mean the online console will be unavailable for a short window. (https://veeamportal.online:6443/)
No action is required as a result of this notification.
If you have any questions relating to this event, please contact the Service Desk team, or speak to your account manager.
Posted Nov 20, 2025 - 13:47 GMT
This scheduled maintenance affected: Veeam Service Provider Console.