Intermittent Connectivity

Incident Report for DCS

Resolved

This issue has been resolved by our operations team, we are investigating to the root cause of the issue
Posted Dec 17, 2025 - 17:37 GMT

Update

We are still resolving this issue. Services are intermittent still
Posted Dec 17, 2025 - 16:58 GMT

Identified

We have identified the cause of the connectivity issue impacting services and have successfully isolated it within the affected network segment.
Our engineering teams are actively working on remediation actions to restore normal service as quickly and safely as possible. Services may remain intermittent during this period.
Further updates will be provided as restoration progresses.
Posted Dec 17, 2025 - 15:46 GMT

Update

Our operations team are still looking into this as a P1 issue
Posted Dec 17, 2025 - 15:08 GMT

Update

We are still actively investigating this. We'll continue to update this page with progress
Posted Dec 17, 2025 - 14:13 GMT

Update

General update:
Further investigations are ongoing. No further updates at this time
Posted Dec 17, 2025 - 13:42 GMT

Investigating

We are currently investigating this issue. Further updates will be provided as they become available.

Next update due at 13:18 hours.
Posted Dec 17, 2025 - 12:20 GMT
This incident affected: CloudCover365 Portal, CloudCover365 Services, Hosting Platform, Veeam Cloud Connect Backup Service, Veeam Cloud Connect Replication Service, Object Storage Leeds, Geo-Failover Replication, and Veeam Service Provider Console.